Needs -I +compiler-libs to compile under ocaml 4.00